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Preface

You can use information in this manual to install any application from the
Optional Applications Software for Windows-Based Oscilloscopes DVD onto
your Microsoft Windows-based Tektronix oscilloscope. For compatibility
information, refer to the table on page 2.

Free Trial

A free trial is available for applications on supported oscilloscopes listed in the
table on page 2. These applications were installed on the supported instrument at
the factory. You can start and exit an application up to five times to help you
evaluate Tektronix software solutions. After five trials, you must purchase an
option installation key to continue to use the application.

NOTE. If a new application becomes available, or a new version of an existing

application is released, you can download the application as described on

page 14 to begin your free trials.
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Product Description

Tektronix provides many applications for Microsoft Windows-based oscillo-
scopes that you can use to test, analyze, and debug various types of electronic
devices and products. To learn about most applications, you can browse the
documentation folder on the Optional Applications Software on Windows-Based

Oscilloscopes DVD, and view any document listed. You can also check
www.tektronix.com for application notes on how to resolve complex problems,
such as how to analyze jitter or how to verify compliance to a serial data
standard.

Tektronix recommends that you upgrade your oscilloscope to the latest firmware
before installing or operating an application. You can download the latest
firmware from www.tektronix.com. To do so, follow the instructions on page 14.
Be sure to select the firmware version appropriate for your specific oscilloscope
model.

NOTE. Be sure to install the oscilloscope firmware before you install any

optional application software.

Application and Oscilloscope Compatibility

The next table lists the applications included on the optional applications DVD
with the compatible oscilloscope models and firmware version numbers.

NOTE. To display the firmware version number of the oscilloscope, select

Help > About TekScope… in the menu bar.

For updates on the applications that are not available on the DVD, refer to the
Software and Downloads section at www.tektronix.com.

For those applications that use the Report Generator, it is installed automatically
when the application is installed. To install the Report Generator manually, refer
to page 12. To install an application, refer to page 11.
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Applications and compatible oscilloscopes

Application name Software version Oscilloscope model
Recommended firmware
version

TDSCPM2 Communications V 3.0.0 and above TDS6124C, TDS6154C V 5.1.5 and above
Pulse Analysis*

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.9 and above

CSA7154, CSA7404, TDS7054,
TDS7104, TDS7154, TDS7254,
TDS7404

V 2.5.5 and above

DPO7054, DPO7104,
DPO7254, DPO7354,
DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.2 and above

TDSDDM2 Disk Drive V 3.0.1 and above TDS6124C, TDS6154C V 5.1.5 and above
Analysis

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

TDS5034, TDS5052, TDS5054,
TDS5104
TDS5034B, TDS5052B,
TDS5054B, TDS5054BE,
TDS5104B

V 2.0.9 and above

CSA7154, CSA7404, TDS7054,
TDS7104, TDS7154, TDS7254,
TDS7404

V 2.5.5 and above

DPO7054, DPO7104, DPO7254

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

TDSDVI DVI Compliance V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovep
Tools

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7254B,
TDS7404B, TDS7704B

V 5.1.3 and above

CSA7404, TDS7054, TDS7404,
TDS6404, TDS6604

V 2.5.3 and above

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

TDSET3 Ethernet Compliance V 3.0.4 and above TDS6124C, TDS6154C V 5.1.5 and abovep
Tools

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

TDS5052B, TDS5054B,
TDS5104B

V 2.0.9 and above

TDS6604, TDS6404 V 2.5.3 and above

CSA7154, CSA7404, TDS6404,
TDS6604, TDS7054, TDS7104,
TDS7154, TDS7104, TDS7154,
TDS7404

V 2.5.5 and above

DPO7054, DPO7104, DPO7254

DPO70404, DPO70604,
DPO70804, DSA70404,

V 3.0.0 and above

, ,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

TDSHT3 V1.2a HDMI V 3.0.1 and above TDS6124C, TDS6154C V 5.1.5 and above
Compliance Tools

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7254B,
TDS7404B, TDS7704B

V 5.1.3 and above

CSA7404, TDS7254, TDS7404 V 2.5.3 and above

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

TDSHT3 V1.3 HDMI Compliance V 3.3.0 and above TDS6124C, TDS6154C V 5.1.5 and abovep
Tools

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7254B,
TDS7404B, TDS7704B

V 5.1.3 and above

CSA7404, TDS7254, TDS7404 V 2.5.3 and above

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

TDSJIT3V2A Jitter and Timing V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and aboveg
Analysis (Advanced) and
TDSJIT3V2E Jitter and Timing

TDS6604B, TDS6804B V 5.1.2 and above
TDSJIT3V2E Jitter and Timing
Analysis (Essentials) CSA7404B, TDS7154B,

TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

TDS5034B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.9 and above

CSA7154, CSA7404, TDS6404,
TDS6604, TDS7054, TDS7104,
TDS7154, TDS7254, TDS7404

V 2.5.5 and above

TDS5034, TDS5054, TDS5104 V 1.2.1 and above

DPO7054, DPO7104, DPO7254 V 3.0.0 and above

DPO70404, DSA70404,
DPO70604, DSA70604,
DPO70804, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

DPOPWR Power Analysis V 1.0.4 and above DPO7054, DPO7104, DPO7254

DPO70404, DSA70404,
DPO70604, DSA70604,
DPO70804, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

RT-Eye V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovey
Eye Analysis and Compliance
Tools�

TDS6604B, TDS6804B V 5.1.2 and above
Tools�

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

CSA7154, CSA7404, TDS6404,
TDS6604, TDS7154, TDS7254,
TDS7404

V 2.5.3 and above

DPO7254
DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

FB-DIMM Compliance Module V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovep
(requires RT-Eye application)

TDS6604B, TDS6804B V 5.1.2 and above

TDS7704B V 5.1.3 and above

TDS6604 V 2.5.3 and above

DPO70604, DPO70804,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

SATA and SAS Test Modules� V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and above
(requires RT-Eye application)

TDS6604B, TDS6804B V 5.1.2 and above

TDS7704B V 5.1.3 and above

TDS6604 V 2.5.3 and above

DPO70604, DPO70804,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

InfiniBand Compliance Module� V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovep
(requires RT-Eye application)

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7404B,
TDS7704B

V 5.1.3 and above

CSA7404, TDS6404, TDS6604,
TDS7404

V 2.5.3 and above

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above

PCI Express Compliance
�

V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovep p
Module� (requires RT-Eye ap-
plication)

TDS6604B, TDS6804B V 5.1.2 and above
plication)

CSA7404B, TDS7404B,
TDS7704B

V 5.1.3 and above

CSA7404, TDS6404, TDS6604,
TDS7404

2.5.3 and above

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

TDSUSB2 USB 2.0 Compliance V 3.0.6 and above TDS6124C, TDS6154C V 5.1.5 and abovep
Tools

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

TDS5034B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.9 and above

CSA7154, CSA7404, TDS6404,
TDS6604, TDS7054, TDS7104,
TDS7154, TDS7254, TDS7404

V 2.5.5 and above

TDS5034, TDS5054, TDS5104 V 1.2.1 and above

DPO7054, DPO7104, DPO7254

DPO70404, DPO70604,
DPO70804, DSA70404,

V 3.0.0 and above

, ,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

TDSPTD Protocol Trigger and V 3.0.2 and above TDS6124C, TDS6154C V 5.1.5 and abovegg
Decode

TDS6604B, TDS6804B V 5.1.2 and above

CSA7404B, TDS7154B,
TDS7254B, TDS7404B,
TDS7704B

V 5.1.3 and above

DPO7254

DPO70404, DPO70604,
DPO70804, DSA70404,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.0 and above
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Applications and compatible oscilloscopes (Cont.)

Application name
Recommended firmware
versionOscilloscope modelSoftware version

TDSVNM CAN/LIN Analysis and
Protocol Decode

V 3.0.4 and above TDS5032B, TDS5034B,
TDS5052B, TDS5054B,
TDS5054BE, TDS5104B

V 2.0.8 and above

TDS7054§, TDS7104§ V 2.5.5 and above

TDS7154B, TDS7254B,
TDS7404B, TDS7704B

V 5.1.3 and above

DPO7054, DPO7104, DPO7254

DPO70404, DPO70604,
DPO70804, DSA70404,

V 3.0.0 and above

, ,
DSA70604, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

TekUWB Ultra Wideband V 2.0.1 and above TDS7704B, TDS6804B V 5.1.2 and above
Spectral Analysis

TDS6124C, TDS6154C V 5.1.5 and above

DPO70804, DSA70804,
DPO71254, DSA71254,
DPO71604, DSA71604,
DPO72004, DSA72004

V 3.0.2 and above

TekConnect Adjust� V 1.11 and above TekScope with TekConnect
devices

All

* Oscilloscope (except CSA7000/B models, DPO7000 and DPO/DSA70000 Series) requires Option SM, serial masks.
� Requires Windows 2000 or Windows XP operating system.
� Does not require an Option Installation Key or the JRE software.
§ Requires Windows 2000.



Optional Applications Installation 9

Application Installation

NOTE. Some applications may require a deskew fixture or a test fixture. The

application online help includes connection procedures for these fixtures.

Install Adobe Reader

NOTE. To view the documentation that comes with the Optional Applications

Software on Windows-Based Oscilloscopes DVD, your system must have Adobe

Reader installed.

The Optional Applications Software on Windows-Based Oscilloscopes DVD
includes the latest Adobe Reader version at the time the DVD was released.
There are two methods to install Adobe Reader:

1. Insert the DVD into the system drive and allow the DVD Browser to
auto-start. This process checks for the latest Adobe Reader and lets you
know if you should upgrade or install Adobe Reader.

2. If you close the DVD Browser or exit the installer early, you can always
access the DVD contents directly. Go to the DVD drive and double-click on
the Launch.exe file. This will launch the DVD Browser. There is an Adobe
Reader link on the browser home page. You can use this link to install the
Adobe Reader.

Reinstalling an Application

Most applications are factory installed on the hard disk in the oscilloscope at the
time the oscilloscope is shipped. The DVD serves as a backup in case you have
to rebuild the hard disk. The Optional Applications Software on Windows--Based

Oscilloscopes DVD may contain applications that were introduced after you
received your oscilloscope.

The optional applications DVD may contain a newer version of the application
software than the version on your oscilloscope. (The latest versions can be found
at www.tektronix.com)

Before you continue, determine if you need to install a newer version of the
application. To do this, follow these steps:
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3. In the menu bar of the TekScope window,
select File > Run Application > <application name>
or App > <application name> or Analyze > <application name> as appropri-
ate for your oscilloscope.

4. In the menu bar of the application, select Help > About <application> to
display the software version number.

5. Check the version number of the application on the Web site. To do so,
follow these steps:

a. Access www.tektronix.com and select Software Downloads.

The Software Downloads and Firmware Finder page appears. To define
the search criteria, use one of the following methods:

� Make selections in the Browse by category Products fields.

� Enter information in the Search by keyword field. For example,
Search by keyword TDSHT3.

b. Select Go. The search returns a list of software.

c. Scroll through the list to the desired application, select the link, and view
the Web page instructions to download the application to your oscillo-
scope. The version number is at the top of the Web page.

If the version number is higher than the version number in the compati-
bility table (on page 2), then follow the Downloading Applications

Through the Web Site procedures on page 14.

The following table shows an example of how to check the application
version numbers and determine whether you need to upgrade the application.

Checking the application software version number example

Application on the
oscilloscope

As listed in the
table on page 2

As shown on the
Web site Reinstall?

V 1.0.0 V 1.0.0 V 1.0.0 No

V 1.0.0 V 1.1.0 V 1.1.0 Yes, from the DVD or
the Web site

V 1.0.0 V 1.1.0 V 1.2.0 Yes, from the Web
site
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Installing an Application

Normally, application software resides on the hard disk of your oscilloscope.
However, you may need to install the application software for the following
reasons:

� You receive an application that was introduced after you received your
oscilloscope.

� You have to rebuild the hard disk of the oscilloscope.

� You download an update for an application from the Tektronix Web site.

The table on page 2 lists the available applications, compatible oscilloscope
models, and the corresponding software version and firmware version numbers.

NOTE. If access is denied when you install an application software on Windows

2000 or Windows XP operating systems, try logging in as an administrator.

The installation procedure may require a mouse attached to the oscilloscope.
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Application Introduced After you Received an Oscilloscope. To install an applica-
tion that does not currently reside on the hard disk of the oscilloscope from the
optional applications DVD, follow these steps:

1. Insert the optional applications DVD in the DVD drive.

2. If the oscilloscope does not automatically start the Installation Browser
program, follow these steps:

a. Select and open theMy Computer icon.

b. In the Exploring - My Computer window, select the drive used in step 1
and then open the Launch.exe file.

3. Select the appropriate button for the application that you want to install.

4. Follow the on-screen instructions given by the InstallShield Wizard. Answer
“OK” if prompted to install the JRE and accept all defaults.

Reboot the oscilloscope to complete the installation.

NOTE. When you install a newer version of software, the existing version is

uninstalled as part of the installation procedure.

If you install a new version of an enabled application, you do not have to enter

the authorized option installation key again.

Installing Report Generator

To install Report Generator from the optional applications DVD, follow these
steps:

1. Insert the optional applications DVD in the DVD drive.

2. If the oscilloscope does not automatically start the Installation Browser
program, follow these steps:

a. Select and open theMy Computer icon.

b. In the Exploring - My Computer window, select the drive used in step 1
and then open the Launch.exe file.

3. Select the Tektronix Report Generator button to install.
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4. Follow the on-screen instructions given by the InstallShield Wizard.

NOTE. If the same version of the Report Generator already exists, a

Modify/Repair or Remove option is displayed in a dialog box. Select the

Modify/Repair option and follow the on-screen instructions to install the Report

Generator.

Applying a New Label

You may need to apply a new authorized option installation key label that comes
in the package with the activation key. It is attached to the rear panel of the
oscilloscope for the following reasons:

� You purchase a software license for an application already installed on the
oscilloscope; the license allows you to enable the application

� You upgrade the licensed application to a newer application

� You purchase an application that was introduced after you received your
oscilloscope

The label contains important information, such as the serial number of the
oscilloscope, options purchased for that serial number, and an authorized option
installation key number. Since each label is unique, apply the new label over the
existing one.

Enabling an Application

You must enter the authorized option installation key to enable all purchased
applications and product options on your oscilloscope. The key is unique; it is
specific to the serial number of the oscilloscope and purchased options.

Follow these steps to enter your alphanumeric key number:

1. If the oscilloscope is powered on in the toolbar mode (default), select the
Menu button (upper right corner of the display) to put the oscilloscope into
the menu-bar mode. In the menu-bar mode you will see a PC-style menu
across the top of the display.

2. Go to the Utilities menu in the menu bar and select Option Installation.

3. Follow the on-screen instructions to enter the alphanumeric key number
exactly as it is printed on the rear-panel label.
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Starting an Application

To start an application, select File > Run > <application name>,
App > <application name>, or Analyze > <application name> from the menu bar
of the oscilloscope.

After installation, the service manuals and the application are available on the
oscilloscope from Start Menu > Programs > TekApplications.

a. In the Exploring - My Computer window, select the drive used in step 2
and then open the Launch.exe file.

Downloading Applications Through the Web Site

You can find information about applications and firmware for your oscilloscope
at www.tektronix.com. Click the Software Downloads link to download updates
to the software and other free applications.

NOTE. When updating an application, the Release Notes file from
www.tektronix.com replaces the Readme.txt file in the Web download self

extracting.exe file.

To download an application to your oscilloscope or personal computer, follow
these steps:

1. Access www.tektronix.com, and select Software Downloads.

The Software Downloads and Firmware Finder page appears. To define the
search criteria, use one of the following methods:

� Select Products and then Oscilloscopes in the Browse by category fields.

� Enter information in the Search by keyword field. For example, Search
by keyword TDSUSB2.

2. Select Go. The search returns a list of software.

3. Browse to and select the link for your software.

Notice that the software link you selected includes other links to view the
Installation Instructions and the Release notes, plus the version number of
the application at the top of the page.

4. Select the Download File button and a MyTek Profile appears.

a. Log on to your MyTek Profile or create a new profile. When finished, a
File Download dialog box appears.
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b. Select Save on the File Download dialog box, and then specify a
location to save to, such as your personal computer or oscilloscope
desktop.

If you saved the downloaded file to your personal computer, you may want
to copy this file to a CD--ROM or a USB memory device to transfer it to
your oscilloscope.

5. To start the installation, double-click the .exe file and follow the on-screen
prompts. To complete the installation, reboot your oscilloscope.
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